This rule detects the presence of URLs associated with the RAT malware family, indicating that an adversary is likely using these specific endpoints for command-and-control or payload delivery. Proactively hunting for these indicators in Azure Sentinel allows the SOC team to identify compromised assets or active threat actor infrastructure before the malware can fully establish persistence or exfiltrate sensitive data.
Threat: rat Total URLs: 5 Active URLs: 0
| URL | Status | Threat | Date Added |
|---|---|---|---|
hxxps://od.lk/s/MTZfMjA1NjE4Mjg1X3Uwdk5H/img_233217.png | offline | malware_download | 2026-09-09 |
hxxps://web.opendrive.com/api/v1/download/file.json/MTZfMjA1NjE3OTY2X2c4UG1u?inline=1 | offline | malware_download | 2026-09-09 |
hxxps://web.opendrive.com/api/v1/download/file.json/MTZfMjA1NjE4Mjg1X3Uwdk5H?inline=1 | offline | malware_download | 2026-09-09 |
hxxps://web.opendrive.com/api/v1/download/file.json/MThfNzM3NzA4MDVfc0cwenI?inline=1 | offline | malware_download | 2026-09-09 |
hxxps://web.opendrive.com/api/v1/download/file.json/MThfNzM3NzA4MDJfaThiVFo?inline=1 | offline | malware_download | 2026-09-09 |
// Hunt for DNS resolution of URLhaus malicious domains
// Threat: rat
let malicious_domains = dynamic(["web.opendrive.com", "od.lk"]);
DnsEvents
| where Name has_any (malicious_domains)
| project TimeGenerated, Computer, Name, IPAddresses
| order by TimeGenerated desc
// Hunt for web traffic to URLhaus malicious domains
let malicious_domains = dynamic(["web.opendrive.com", "od.lk"]);
CommonSecurityLog
| where RequestURL has_any (malicious_domains) or DestinationHostName has_any (malicious_domains)
| project TimeGenerated, SourceIP, RequestURL, DestinationHostName, DeviceAction
| order by TimeGenerated desc
| Sentinel Table | Notes |
|---|---|
CommonSecurityLog | Ensure this data connector is enabled |
DnsEvents | Ensure this data connector is enabled |
http://192.168.x.x:8080/upload.php?file=...).
https://internal-cfg.corp.com/config?ver=2.1&token=abc123).
.corp.com or .internal AND the process name is powershell.exe or pwsh.exe initiated by a service account (e.g., DOMAIN\svc-deploy).