← Back to SOC feed Coverage →

Veeam Backup Database Suspicious Query

sigma MEDIUM SigmaHQ
T1005
imProcessCreate
This rule was pulled from an open-source repository and enriched with AI. Validate in a test environment before deploying to production.
View original rule at SigmaHQ →
Retrieved: 2026-05-20T11:00:00Z · Confidence: medium

Hunt Hypothesis

Detects potentially suspicious SQL queries using SQLCmd targeting the Veeam backup databases in order to steal information.

Detection Rule

Sigma (Original)

title: Veeam Backup Database Suspicious Query
id: 696bfb54-227e-4602-ac5b-30d9d2053312
status: test
description: Detects potentially suspicious SQL queries using SQLCmd targeting the Veeam backup databases in order to steal information.
references:
    - https://labs.withsecure.com/publications/fin7-target-veeam-servers
author: Nasreddine Bencherchali (Nextron Systems)
date: 2023-05-04
tags:
    - attack.collection
    - attack.t1005
logsource:
    category: process_creation
    product: windows
detection:
    selection_sql:
        Image|endswith: '\sqlcmd.exe'
        CommandLine|contains|all:
            - 'VeeamBackup'
            - 'From '
    selection_db:
        CommandLine|contains:
            - 'BackupRepositories'
            - 'Backups'
            - 'Credentials'
            - 'HostCreds'
            - 'SmbFileShares'
            - 'Ssh_creds'
            - 'VSphereInfo'
    condition: all of selection_*
falsepositives:
    - Unknown
level: medium

KQL (Azure Sentinel)

imProcessCreate
| where (TargetProcessName endswith "\\sqlcmd.exe" and (TargetProcessCommandLine contains "VeeamBackup" and TargetProcessCommandLine contains "From ")) and (TargetProcessCommandLine contains "BackupRepositories" or TargetProcessCommandLine contains "Backups" or TargetProcessCommandLine contains "Credentials" or TargetProcessCommandLine contains "HostCreds" or TargetProcessCommandLine contains "SmbFileShares" or TargetProcessCommandLine contains "Ssh_creds" or TargetProcessCommandLine contains "VSphereInfo")

Required Data Sources

Sentinel TableNotes
imProcessCreateEnsure this data connector is enabled

False Positive Guidance

MITRE ATT&CK Context

References

Original source: https://github.com/SigmaHQ/sigma/blob/master/rules/windows/process_creation/proc_creation_win_sqlcmd_veeam_db_recon.yml